Настройка использования средств криптографии KalkanCrypt в ОС семейства Linux

  1. Разместить библиотеку libkalkancryptwr-64.so (находится в каталоге C\Linux\C в комплекте разработчика НУЦ РК) в системной директории, где хранятся библиотеки и модули, используемые программами в системе по пути /usr/lib/.
  2. Установить в операционной системе корневые сертификаты НУЦ РК. Сертификаты также предоставляются с комплектом разработчика НУЦ РК (находятся в каталоге C\Linux\ca-certs). Для их установки необходимо следовать инструкциям, которые находятся в каталогах комплекта. Например, для операционных систем Ubuntu необходимо распаковать архивы в каталоге сертификатов и запустить файл сценария install_production.sh с необходимыми правами пользователя.

Были выполнены вышеперечисленные шаги, но не работает, может есть более подробная инструкция для Centos 7?

1 Симпатия

Доброго времени суток!

Второй день пытаюсь запустить данную библиотеку!
Моя конфигурация:

  1. Сервер 1С:Предприятия платформа 8.3.24.1467,
    ОС Debian Linux 10.8 со всеми обновлениями на текущий момент.
    СУБД PostgreSQL 11.1C
    Конфигурация Бухгалтерия для Казахстана 3.0.55.1

  2. Клиент ОС Debian Linux 12.5 с последними обновлениями на текущий момент
    1С:Предприятие платформа 8.3.24.1467

Библиотеку и сертификаты положил и на сервер и на клиенте в соответствующие каталоги.
По при попытке Проверить доступ к порталу ЭСФ из настроек или при попытке откравить ЭАВР или ЭСФ выдает ошибку, что библеотека не найдена в системном каталоге. Screenshot_20240408_191227

Мы нашли причину, ​​библиотеки kalkancrypt ОС Linux предназначены собраны для glibc 2.28, у нас glibc 2.17. Просим НУЦ выслать нам соответствующие библиотеки собранные под glibc 2.17
%D0%B8%D0%B7%D0%BE%D0%B1%D1%80%D0%B0%D0%B6%D0%B5%D0%BD%D0%B8%D0%B5

1 Симпатия

Доброе утро! Обновите SDK через https://pki.gov.kz/get-sdk. Там либы собраны под старый glibc

Screenshot_20240521_103859

Доброго дня.

долгое время не мог разобраться с подпиской ИТС для 1С, сегодня все подключили.
Но при попытке проверить доступ к порталу ИС ЭСФ выдается такая ошибка. библиотека Kalkan 2.0.2

Добрый день!
Подскажите, с версией 2.0.12 ошибка сохраняется?

Пришлось обновить ОС и после этого заработало

А подробнее можете описать?
Чтобы другие пользователя, если встретили такую ошибку, знали “где собака зарыта”

Для начала перешли с Centos7 на Almalinux8 а далее по инструкции